Skip to main content

Can't boot on bootable USB with manjaro 17.0 community edition i3 [Resolved]

I would like to try this distribution, I made a bootable USB drive that I was able to use on my laptop but I can't make it work on my main PC.
Here is a screenshot of what's happening at boot time enter image description here

I have to boot with kernel set to 'safe' to have this screen, otherwise I am stuck on a black screen

Regarding

Unable to init device /dev/mcelog (rc: -5)

Seems to be related with nouveau driver, not sure it is the reason why the system cannot be initiated. I would rather use proprietary driver later on anyway.

unable to locate ioapic for gsi 51

Seems to be related to 4.8 and harmless (src https:// bbs.archlinux.org / viewtopic.php?id=218566)

usb 1-1: device not accepting address 2, error -110

I tried what is advised here but had been unsuccessful

Also tried all USB ports

EDIT

From the UEFI menu I had two options to boot from my usb stick (sandisk), * UEFI Sandisk * Sandisk

According to the one I pick it drives me to two possible screen

The UEFI option (screen 1) enter image description here

The non UEFI option (screen 2) enter image description here


Asked March 20, 2017
Posted Under: Unix Linux
5 views
2 Answers

Pick the UEFI option only if you know exactly what you're doing. So pick the non-UEFI option, select the Start Manjaro Linux option, then follow below instructions.

Select the Live CD entry in the boot menu, press E on your keyboard and replace quiet splash with nomodeset. If you don't find quiet splash, just look for the second last line and place nomodeset after ro.


Answered March 20, 2017
 
I can also access the bootable device through grub thanks to my actual linux. From there I might add the parameter you are talking about. here is my actual boot entry : search --fs-uuid --no-floppy --set=root 5DD6-EE22 chainloader (${root})/EFI/boot/bootx64.efi – zakrapovic 2 days ago
 CanDoerz  2 days ago
 
I updated the very end of the post so maybe you can help me booting in non UEFI mode form the HDD. thanks – zakrapovic 2 days ago
 CanDoerz  2 days ago
 
I have nowhere the opportunity to press E and do such a thing, once I pick Start Manjaro Linux I do not have hand anymore. Maybe it is something you can do with other kind of bootable distro, manjaro is based on arch linux which might include component you are not familiar with. – zakrapovic 2 days ago
 CanDoerz  2 days ago
 
Updated my answer. – Akito 2 days ago
 CanDoerz  2 days ago
 
I updated the thread, I do not see where I have the opportunity to add such parameters. There is no grub bootloader so far. thanks anyway for helping – zakrapovic 2 days ago
 CanDoerz  2 days ago

Errors from the non UEFI mode in the end were misleading.
So far the UEFI path led me to blackscreen, but it is actually the one to pick. The problem is that with this grub you cannot modify kernel parameters on the fly by pressing E. Doing it bring a line *initrd=/.../ * with the path to initrd but you cannot scroll to the left or right to get to the options we are looking for. To specify the nomodeset option I had to modify *loader/entries/manjaro-[arch].conf and substitute

nouveau.modeset=1 i915.modeset=1 radeon.modeset=1

by

nomodeset=1

By doing that it keep the native resolution and you can see the log going on.
At some point it stopped at line

OK start account service

By doing Ctrl+Alt+F2 you can get to a terminal windows and login as user manjaro pwd manjaro
From there you can acces journal

journalctl -b

And see what went wrong, in my case the driver of my graphic card are not taken into account properly

EDIT
Apparently nouveau do not handle my graphic card correctly but if you pick non-free driver it can work
In you bootable manjaro USB, in *loader/entries/manjaro-[arch]-nonfree.conf substitute

nouveau.modeset=1 i915.modeset=1 radeon.modeset=1

by

nomodeset=1

Reboot in UEFI mode, select Start Manjaro nonfree, and that's it!


Answered March 20, 2017
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA