Skip to main content

Invalid command 'AuthAuthoritative' [Resolved]

i'm trying to start apache2 serveur so I configured the httpd.conf and an error appears

Invalid command 'AuthAuthoritative', perhaps misspelled or defined by a module not included in the server...iguration

this is the config in httpd.conf :

    AllowOverride           all

    Satisfy                 any

    AuthAuthoritative       on
    AuthUserFile            /home/netmet/netMet/etc/apache.passwd
    AuthGroupFile           /home/netmet/netMet/etc/apache.group
    AuthName                "netMET access's"
    AuthType                Basic
    require                 group netmet netmet-cgi

    order                   deny,allow
    deny from               all
    allow from              host.domain.fr

Any ideas ?? thanks


Asked April 21, 2017
Posted Under: Unix Linux
40 views
1 Answers

Remember to load mod_auth. If you use some distribution that has a2enmod, it is just a2enmod auth.


Answered April 21, 2017
 
Then you need to install that module, your distribution probably has it in some package. – Henrik 47 mins ago
 CanDoerz  3 months ago
 
Sorry about that, too long since I've done anything with a2enmod. – Henrik 49 mins ago
 CanDoerz  3 months ago
 
@MichaelHomer same result ERROR: Module auth does not exist! – alex 49 mins ago
 CanDoerz  3 months ago
 
@alex It's just a2enmod auth, generally. – Michael Homer 51 mins ago
 CanDoerz  3 months ago
 
I tried and ERROR: Module mod_auth does not exist! – alex 52 mins ago
 CanDoerz  3 months ago
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA