Skip to main content

Access a TFS Server inside a Hyper-V VM [Resolved]

I'm running a TFS (2013) Server inside a Windows Server 2008 R2 Hyper-V VM (hosted on Windows 8). Everything seems to be running correctly within the server; however, when I try to connect to the Web URI of the TFS Server, I can't seem to see the server.

The VM is using a static IP and is able to see the network. I can access the VM from the network (i.e. if I type \servername\ into explorer it shows the VM exists)

What can I try / do to diagnose or fix this issue? Is there something specific that I need to do to TFS to cause it to be exposed to the network via a VM?

There server is accessible from within the VM.


Question Credit: pm_2
Question Reference
Asked October 11, 2017
Posted Under: Network
32 views
2 Answers

Make sure you have disabled the Firewall. Also, disable Loopbackcheck on the TFS Server:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. Right-click Lsa, point to New, and then click DWORD Value.
  4. Type DisableLoopbackCheck, and then press ENTER.
  5. Right-click DisableLoopbackCheck, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Exit Registry Editor.
  8. Restart the computer.

and Disable StrictNameChecking:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and click the following key in the registry: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
  3. On the Edit menu, click Add Value, and then add the following registry DWORD value: DisableStrictNameChecking
  4. Right-click DisableStrictNameChecking, and then click Modify.
  5. In the Value data box, type 1, and then click OK.
  6. Exit Registry Editor.
  7. Restart the computer.

credit: MichelZ
Answered October 11, 2017
 
Yep - it was the firewall! Many thanks for your help! – pm_2 Feb 17 '14 at 14:04
 CanDoerz  2 months ago
 
+1 for disabling the firewall. I had a similar issue with my TFS2012 server I had setup as a VMware server. Shutting off the firewall fixed it. Another thing to check, can you access the Web-side of TFS through your browser? – Lee Harrison Feb 14 '14 at 14:38
 CanDoerz  2 months ago

While I agree with MichelZ's answer, in my case the problem was that I was trying:

http://MyTfsExperience:8080/tfs/

instead of:

http://MyTfsExperience.westeurope.cloudapp.azure.com:8080/tfs/

What I mean is that the machine name is not enough. You need (obviously) the complete URL.


credit: Luis Gouveia
Answered October 11, 2017
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA