Skip to main content

primary.sqlite.bz2 not found on private repo [Resolved]

I've been setting up a private repo for the company I'm working. At the beginning it was working properly, but today, when I'll try to install a new rpm that I've build I had this ugly error :

http:///centos/7/repodata/a6ecd0c880b1f5128974cd147a53cd84d7dab269b9055215b6fbe99fb98f6d7a-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found-:-- ETA

I've already tried :

yum clean all
rm -rf /var/cahe/yum
yum repolist

And again the same error.

I've erased all the contents under repodata on the repo server and recreate the repo again with :

createrepo /path/to/repo/directory

After recreate the repo againg I've ran again

yum clean all
rm -rf /var/cahe/yum
yum repolist

But still nothing working

I'm 100% sure that the client configuration is OK, because I'm the only one playing with the servers for the moment and last week it was working well.

Otherwise the repo is accessible in http, I can see all packages and repodata with a web browser. If a execute

curl http:///centos/7/repodata/repomd.xml

from the client, I get the correct file.

I've realized that the name of the primary DB name is not the correct one in the client (even after running yum clean all; rm-rf /var/cache/yum; yum update). How can I fix this please ? I've been all the afternoon digging into this problem but nothing changes

Permissions in repo directories are setup OK (triple checked)

What I'm missing ???

Thank you in advance for your help


Question Credit: Abel
Question Reference
Asked December 7, 2017
Posted Under: Network
60 views
1 Answers

I think that I've found the answer yesterday night, at least for the moment I'm not facing the problems descrived before.

The solution is simple, avoid that client keep a local cache of the repos. This can be done including in /etc/yum.conf clients file the next line :

http_caching=none

With this option set up, each time the client executes a yum updateor yum repolist it downloads all the repodata from the repository server, so all the files are in their last version.

I still do not understand why if I was erasing all the local cache in the client with yum clean all; rm -rf /var/cache/yum the client kept searching for old repodata files. If someone has an answer please share it. It drove me crazy for the last few days.

Thank you anyway for yous tips and advices


credit: Abel
Answered December 7, 2017
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA