Skip to main content

Cannot boot to twrp recovery after rooting second time [Resolved]

I have rooted my Redmi 1s one year ago, and installed TWRP using Twrp Manger, and flashed custom ROM (Cyanogenmod and then Lineage Os). And, now I returned back to stock MIUI ROM. Again, I rooted my device and tried to install TWRP. TWRP got installed (I tried different versions of img and zip of twrp), and I cannot boot to TWRP recovery mode. I also tried fastboot methods to install TWRP which also got failed while booting.

I followed the same steps for rooting that I have done for the first time. Rooted using Super Su (source from miui forum). Checked using root checker, shows status as rooted. Tried to install twrp using, twrp manager(success but can't boot to recovery), twrp official app(success but can't boot to recovery) and rashr (got failed, it tells I have installed twrp already). I flashed Philz clockworkmod using fastboot, and booted to recovery mode. I have less experience with CWM. so, I need to set twrp as my recovery. How to solve?


Question Credit: Rahul Gopi
Question Reference
Asked May 14, 2018
Posted Under: Android
36 views
1 Answers

It was a firmware issue. TWRP requires latest firmware/ROM to be installed. Otherwise twrp get stuck at teamwin logo.

I installed latest MIUI ROM (MIUI 8.2.1) on my device and rooted it and installed latest TWRP image(3.1.1) using fast boot. It booted to twrp recovery successfully.


credit: Rahul Gopi
Answered May 14, 2018
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA