Skip to main content

After upgrade to HighSierra Finder's Sidebar do not work anymore [Resolved]

I have a 13" early 2014 MacBook Air which had been running El Capitan for some time now. Yesterday I successfully upgraded to High Sierra (10.13.3), but since then a problem keeps occuring:

All "Favorites" and some "Devices" have the generic file icon (looking like a sheet of paper with a dog-ear). When clicked, the system thinks for a few seconds (rotating beach ball) and then displays an error, e.g.:

"Documents" can't be opened because the original item can't be found.

As you can see, this happens to custom as well as to system Favorites.

So, my question is: How can I restore Finder's full functionality?

What I've tried so far:

  • Turning it off and on again
  • Force-quitting Finder
  • Trying to delete the not-working Favorites (beach ball, error from above, Favorite still there)
  • Trying to change Finders side bar's preferences (Initially: No Favorites' boxes are checked, if checked by me, they become unchecked again after a few seconds. Now: Trying to access the side bar ridget of Finder's preferences invokes the beach ball until I close the menue.)
  • Trying to delete com.apple.finder.plist and com.apple.sidebar.plist from ~/Library/Preferences/ restarting imidiately afterwars (result: Looks to be working for a few seconds after restart, then back to old problem. However, my custom fevorites are gone, only the default ones remain.)

Some additional information:

  • It is possible, to access the directories manually. They do exist and have not moved (as far as their path is concerned).
  • The user name did not change.
  • "Go To" works fine.

Question Credit: Fantilein1990
Question Reference
Asked May 14, 2018
Posted Under: Apple
41 views
2 Answers

Two things could be going on here:

1

First with the introduction of macOS High Sierra you can now synchronise your Desktop and Documents folders with iCloud Drive.

macOS does some screwy things with them as officially they are actually still in /Users/{username}/(Desktop|Documents) which you'd expect but Finder relocates them into iCloud Drive if you have this feature enabled, this could be why your old shortcuts aren't working.

Screenshot indicating the new location of iCloud drive Desktop and Documents folders

If this isn't something you want you could disable this by going to System Preferences > iCloud > iCloud Drive and unchecking "Desktop & Documents Folders"

2

The system update didn't go quite to plan, this is the route of trouble shooting you've already been testing and the work you've done so far is perfect.

2a

Next steps assuming it's not just what I've said in option 1 above, would be to create a new user account, and see if that resolves the issues. If it does you can use the /Users/Shared folder to transfer all your files manually, but you will need to re-setup all your preferences and some software may have only been licensed in that user account, not across the system, but from what you've described you seem pretty technically competent and would be able to manage that, if not come back and we can give you further help.

2b

If that also didn't work you should backup your files manually, and perform a full system restore, there are instructions on Apple.com here:

macOS Sierra: Erase and reinstall macOS

The instructions are the same for High Sierra.


credit: unknowndomain
Answered May 14, 2018

If you right-click on the generic icon and choose "remove from sidebar" you may then repopulate the sidebar with whichever folders you had there before


credit: user288993
Answered May 14, 2018
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA