Skip to main content

Disable spellcheck and autocorrect in Notes forever [Resolved]

I've googled plenty of guides about disabling spelling and grammar in mac's Notes, and while unchecking the items in the edit menu works fine for the note I'm currently on, it turns back on for each new note and requires me manually disabling it each time.

I would like it to never check spelling and grammar in Notes, and not substitute incorrect spellings (not swapping out for smart quotes and the like would be a bonus). Is there some way to permanently disable these features for just the one app?

To be clear I don't want to disable it system-wide, only in Notes.


Question Credit: Alex
Question Reference
Asked September 22, 2018
Posted Under: Apple
11 views
2 Answers

Autocorrect is controlled by the NSAutomaticSpellingCorrectionEnabled key. You can set this in the Notes app preferences for it to apply consistently.

defaults write com.apple.notes NSAutomaticSpellingCorrectionEnabled -bool false

Reset with defaults delete com.apple.notes NSAutomaticSpellingCorrectionEnabled.


credit: grg
Answered September 22, 2018
Edit>Spelling and Grammar>Correct Spelling Automatically 

This worked for me. It is sometimes unclickable, if that is the case click a note and write something in this. This action will make it clickable.


credit: Esqarrouth
Answered September 22, 2018
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA