Skip to main content

Rescue data from Powerbook G4 with forgotten password [Resolved]

I have a Powerbook G4 whose owner forgot her password.

(This is a Powerbook 6,8. The install disk says OSX 10.4 but I don't know if it's been upgraded.)

I can't insert the install disk into the optical drive (it encounters a solid resistance - I can't tell if there's another disk in there or not, but pressing Eject does nothing, and I don't see any hole in which to poke a paperclip to try to manually eject it).

I found a recommendation to:

  • boot into single-user mode
  • run fsck -fy
  • mount -uw /
  • rm /var/db/.AppleSetupDone
  • reboot

which supposedly would take me through creating a new (admin) user account, which I could then use to reset the owner's password. It rebooted, asked me what language I wanted to use, and after that, nothing (it briefly showed the spinning gear, changed the screen color a couple of times, showed the spinning gear, changed screen color, ad infinitum).

I did manage, from single user mode, to use Unix commands to verify that the owner's home directory still existed. I also inserted a flash drive into a USB port hoping I might use Unix 'cp' to copy the home directory onto it, but it didn't appear in the /Volumes directory.

Now the machine boots up to the window asking what language to use, and goes no further. And as I mentioned, the optical drive doesn't appear to work.

Before I go out and buy a FW 400-800 cable and a FW800-Thunderbolt adapter to try and mount the PB in firewire mode to my 2012 MBP, I wondered if someone could suggest any other things to try.

UPDATE in response to Gordon Davisson:

Output of sw_vers

  • ProductName: Mac OS X
  • ProductVersion: 10.4.11
  • BuildVersion: 8S165

Output of ls /dev/disk*

  • /dev/disk0 /dev/disk0s1 /dev/disk0s3

Output of ls /dev/disk* after plugging in flash drive

  • /dev/disk0 /dev/disk0s1 /dev/disk0s3 (same)

Output of diskutil list

  • Command never completed! (I also tried rebooting and issuing command without flash drive inserted - same result.)

I reran fsck -fy but got a clean bill of health.

[UPDATE]: There is no disk in the optical drive, but a mechanical "stop" that is apparently designed to hold the CD in has moved into place as if a CD were there. This is what is preventing my inserting a CD.

[UPDATE]: All suggestions were useful but were stymied by other unforeseen problems (optical drive problem, etc.). I finally paid about $35 for a Firewire 400-800 cable and a Firewire->Thunderbolt adaptor, booted the laptop into FW target mode, and successfully copied the home folder (about 40GB) onto my Mac. The laptop may be a brick at this point, but the data is rescued. Mission accomplished.

Question Credit: Chap
Question Reference
Asked February 11, 2019
Posted Under: Apple
3 Answers

I don't have a 10.4 system available to test with, but I think you should be able to get enough of the OS running to access a USB flash drive by going into single-user mode, then running the command sh /etc/rc. If that doesn't work to mount the flash drive, try running ls /dev/disk* again and see what if it lists /dev/disk1 and /dev/disk1s; if it does, you should be able to mount the drive manually with mkdir /Volumes/flash and mount /dev/disk1s<something> /Volumes/flash. If that doesn't work, you might have to specify the volume type with e.g. mount -t hfs /dev/disk1s<something> /Volumes/flash (for a Mac-formatted drive) or mount -t msdos /dev/disk1s<something> /Volumes/flash (for a FAT-formatted drive).

credit: Gordon Davisson
Answered February 11, 2019

I recently needed to reset the password on my iBook G4 (PowerBook 6,5) and I did it like this:

  1. Restart the machine and hold command (the apple key) and S key while it is turning on until you see some text. This starts the machine in single user mode.

  2. Next, you need to mount the file system and make it writeable with the following commands:

    /sbin/fsck -fy

    /sbin/mount -uw /

    sh /etc/rc

Type the first command above, then click enter and wait until the process stops. (You know the process has stopped when you have a # after the "root.") Then, type the second command and click enter and wait until the process stops. Then, type the third command and click enter and wait until the process stops.

(Tips: 1. The spaces in the commands are important. 2. If the process seems to hang, press the enter key a few times.)

  1. Enter your new password and click enter. (You will not see the password as you type it, and the cursor will not move.)

  2. Enter your new password a second time and click enter. (You will not see the password as you type it, and the cursor will not move. It will look like nothing is happening.)

  3. Reboot the little monster. (Type reboot and then hit enter.)

credit: lillianna marie
Answered February 11, 2019
Your Answer