Skip to main content

How to install Brotli on nginx and Ubuntu 18.04? [Resolved]

I installed Brotli on Ubuntu 18.04 with Nginx.

Here is the procedure I followed :

$ sudo apt-add-repository ppa:hda-me/nginx-stable
$ sudo apt update
$ sudo apt install brotli nginx nginx-module-brotli

With the tutorial of this blog :

https://clearleft.com/posts/a-dive-into-serving-brotli-compressed-assets

ubuntu@www-example-com ~ $ nginx -V 2>&1 | tr ' ' '\n' | grep brotli

--add-dynamic-module=debian/extra/ngx_brotli

Here is the error message when I test Nginx :

ubuntu@www-example-com ~ $ sudo nginx -t

nginx: [emerg] "load_module" directive is not allowed here in /etc/nginx/sites-enabled/www-s1biose-com:35
nginx: configuration file /etc/nginx/nginx.conf test failed

My configuration seems correct. What's wrong ?

server {
    listen 80 default_server;
    listen [::]:80 default_server;
    server_name example.com www.example.com;

    location ^~ /.well-known/acme-challenge/ {
        default_type "text/plain";
        root /var/www/letsencrypt;
    }

    location / {
        return 301 https://www.example.com$request_uri;
    }
}

server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name www.example.com;
    root /var/www/www-example-com/web;
    index index.php;

    ssl_certificate /etc/letsencrypt/live/www.example.com/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/www.example.com/privkey.pem;
    include /etc/letsencrypt/options-ssl-nginx.conf;
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem;

    add_header X-Frame-Options "SAMEORIGIN" always;
    add_header X-XSS-Protection "1; mode=block" always;
    add_header X-Content-Type-Options "nosniff" always;
    add_header Referrer-Policy "no-referrer-when-downgrade" always;
    add_header Content-Security-Policy "default-src * data: 'unsafe-eval' 'unsafe-inline'" always;
    add_header Strict-Transport-Security "max-age=31536000; includeSubDomains; preload" always;

    load_module modules/ngx_http_brotli_static_module.so;
    load_module modules/ngx_http_brotli_filter_module.so;

    gzip on;
    gzip_vary on;
    gzip_proxied any;
    gzip_comp_level 6;
    gzip_types text/plain text/css text/xml application/json application/javascript application/xml+rss application/atom+xml image/svg+xml;

    brotli on;
    brotli_comp_level 6;
    brotli_types text/plain text/css text/xml application/json application/javascript application/xml+rss application/atom+xml image/svg+xml;

    expires 1209600s;

    location = /favicon.ico {
        log_not_found off;
        access_log off;
    }

    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }

    location ~* \.(txt|log)$ {
        deny all;
    }

    location ~ \..*/.*\.php$ {
        return 403;
    }

    location ~ ^/sites/.*/private/ {
        return 403;
    }

    location ~ ^/sites/[^/]+/files/.*\.php$ {
        deny all;
    }

    location ~* ^/.well-known/ {
        allow all;
    }

    location ~ (^|/)\. {
        return 403;
    }

    location / {
        try_files $uri /index.php?$query_string;
    }

    location @rewrite {
        rewrite ^/(.*)$ /index.php?q=$1;
    }

    location ~ /vendor/.*\.php$ {
        deny all;
        return 404;
    }

    location ~ '\.php$|^/update.php' {
        expires off;
        fastcgi_split_path_info ^(.+?\.php)(|/.*)$;
        include fastcgi_params;
        fastcgi_param HTTP_PROXY "";
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_param QUERY_STRING $query_string;
        fastcgi_intercept_errors on;
        fastcgi_pass unix:/var/run/php/php7.3-fpm.sock;
    }

    location ~ ^/sites/.*/files/styles/ {
        try_files $uri @rewrite;
    }

    location ~ ^(/[a-z\-]+)?/system/files/ {
        try_files $uri /index.php?$query_string;
    }

    location ~* \.(js|css|png|jpg|jpeg|gif|ico|svg)$ {
        try_files $uri @rewrite;
        expires max;
        log_not_found off;
    }
}

server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name example.com;

    ssl_certificate /etc/letsencrypt/live/www.example.com/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/www.example.com/privkey.pem;
    include /etc/letsencrypt/options-ssl-nginx.conf;
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem;

    add_header X-Frame-Options "SAMEORIGIN" always;
    add_header X-XSS-Protection "1; mode=block" always;
    add_header X-Content-Type-Options "nosniff" always;
    add_header Referrer-Policy "no-referrer-when-downgrade" always;
    add_header Content-Security-Policy "default-src * data: 'unsafe-eval' 'unsafe-inline'" always;
    add_header Strict-Transport-Security "max-age=31536000; includeSubDomains; preload" always;

    location / {
        return 301 https://www.example.com$request_uri;
    }
}

Here is the list of installed packages :

ubuntu@www-example-com ~ $ dpkg -l |grep nginx

ii  libnginx-mod-http-geoip         1.14.0-0ubuntu1.2                                        amd64        GeoIP HTTP module for Nginx
ii  libnginx-mod-http-image-filter  1.14.0-0ubuntu1.2                                        amd64        HTTP image filter module for Nginx
ii  libnginx-mod-http-xslt-filter   1.14.0-0ubuntu1.2                                        amd64        XSLT Transformation module for Nginx
ii  libnginx-mod-mail               1.14.0-0ubuntu1.2                                        amd64        Mail module for Nginx
ii  libnginx-mod-stream             1.14.0-0ubuntu1.2                                        amd64        Stream module for Nginx
ii  nginx                           1.15.8-1-ppa7~bionic                                     amd64        high performance web server
ii  nginx-common                    1.14.0-0ubuntu1.2                                        all          small, powerful, scalable web/proxy server - common files
ii  nginx-core                      1.14.0-0ubuntu1.2                                        amd64        nginx web/proxy server (standard version)
ii  nginx-module-brotli             1.15.8-1-ppa7~bionic                                     amd64        Brotli Module
ii  python-certbot-nginx            0.28.0-1+ubuntu18.04.1+certbot+3                         all          transitional dummy package
ii  python3-certbot-nginx           0.28.0-1+ubuntu18.04.1+certbot+3                         all          Nginx plugin for Certbot

Question Credit: ML61
Question Reference
Asked March 13, 2019
Posted Under: Network
10 views
1 Answers

The load_module directive can only appear at the top level of the nginx configuration. It cannot be inside any block.

Most likely your existing distro-provided nginx configuration already has something at the top level that loads modules from a preconfigured directory. Consider taking advantage of that.


credit: Michael Hampton
Answered March 13, 2019
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA