Skip to main content

Limit CUPS printer discovery from multiple interfaces [Resolved]

ServerFault! Coming here right from StackOverflow :)

Here is the problem: I have a Xubuntu PC that has two physical network interfaces. One of them is for purposes of my working room, another is to connect to other rooms in a building.

CUPS detects every single damn printer there is in a whole building. At least, those that are somehow ended up in that network. How do I make CUPS NOT to scan this external interface for printers? It should be up all the time.

Thanks in advance :)


Question Credit: Leontyev Georgiy
Question Reference
Asked April 14, 2019
Posted Under: Network
45 views
1 Answers

I think what you're looking for is a configuration in cups-browsed.conf to deny printers of your "external" interface, e.g.:

# forbid browsing of external network
BrowseDeny 192.168.3.0/24

or

# forbid all,
BrowseDeny All

# then allow your local printers
BrowseAllow 192.168.7.20
BrowseAllow 192.168.7.21

Also have a look at the BrowseFilter options.


credit: Freddy
Answered April 14, 2019
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA