Skip to main content

Volume keys only react on every second hit [Resolved]

I'm using a Tuxedo InfinityBook with elementary OS 0.4.1 Loki.

When I hit FN + VOL. UP/DOWN, the changes only take effect on every second hit. So, to lower or raise the volume by one step, I have to hit FN + VOL. UP/DOWN] twice.

I noticed that the system seems to "save the state" of the volume bar even though no changes take place: When I hit FN + VOL. DOWN and FN + VOL. UP in a row, nothing happens, but when I do the same again after that, the volume first decreases and then increases by one step, as one would expect. I hope, this is understandable.

Strange thing is, this bug is also present when I boot another OS from a Live USB...

Also, the "underlying buttons", which are "?" and "`´" in my case, work normally.

I tried to set other key combinations to raise/lower volume via dconf-editor (e.g. "Super + O"), then it works fine! I want to use my native media keys for this though, so this is not an acceptable workaround.

Typing gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up in the terminal, as suggested by many, also doesn't solve it.

This problem only occurs with the volume buttons, e.g. the brightness keys, mute key,... work as expected.

I've run out of ideas by now – maybe anyone has experienced similar issues and managed to solve them?


Question Credit: bellackn
Question Reference
Asked May 13, 2019
Posted Under: Unix Linux
30 views
1 Answers

Turned out this could be reproduced by the manufacturer, but they won't put any effort into it because my notebook from 2015 is apparently too old... Seems to be related to something on hardware side, so I don't see a realistic chance to get this fixed and therefore closing this thread.


credit: bellackn
Answered May 13, 2019
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA