Skip to main content

TWRP unable to wipe or format `Failed to mount '/system' (Device or resource busy)` [Resolved]

I'm trying to install LineageOS and then GAPPS on my Pixel XL from TWRP recovery. I'll try to Advance Wipe the /systems directory and Format Data, but I continue to get multiple errors:

Failed to mount '/system' (Device or resource busy)

Failed to mount '/vendor' (Device or resource busy)

And

Unable to wipe 'System'

Unable to wipe '/system'

 to

If I just continue with adb sideload lineageos.zip most of the time it stops about halfway (PowerShell shows 47%) through and then TWRP shell shows:

Installing zip file '/sideload/package.zip'
Step 1/2
Step 2/2

I then try to sideload the gapps.zip file and get another error saying /system doesn't have enough space. I've tried sideloading several different gapps versions including their smallest pico zip fie of 91.39 MiB.

I am able to then boot into LineageOS, but no GAPPS show and I'm not able to run any new apps installed via APK without them crashing.

My assumption is that I need to fully wipe system and format it, but I've been trying for two days now and still get the above (Device or resource busy) errors. Any help would be much appreciated!


Question Credit: orangeMint
Question Reference
Asked July 9, 2019
Posted Under: Android
70 views
1 Answers

I fixed this by using an older version of TWRP (3.2.3.1), then I downloaded GAPPs from a different source and installed using adb sideload now all is working.


credit: orangeMint
Answered July 9, 2019
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA