Skip to main content

ModSecurity dependency not found? [Resolved]

1. yum groupinstall 'Development tools'
2. yum install -y geoip-devel libcurl-devel libxml2-devel libxslt-devel libgb-devel lmdb-devel openssl-devel pcre-devel perl-ExtUtils-Embed yajl-devel zlib-devel
3. cd /opt
4. git clone --depth 1 -b v3/master https://github.com/SpiderLabs/ModSecurity.git
5. cd ModSecurity
6. git submodule init
7. git submodule update
8. ./build.sh
9. ./configure

And below is the result

enter image description here

As we can tell, step 2 we have installed yajl-devel and geoip-devel but why is the dependencies not found?

UPDATES:

Realized when I try to install geoip-devel and yajl-devel individually, both giving me No Package available error. Wondering how should I install them?

Below is the output

[root@ip nginx]# yum install -y geoip-devel
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
No package geoip-devel available.
Error: Nothing to do

Question Credit: Isaac
Question Reference
Asked July 21, 2019
Posted Under: Network
27 views
1 Answers

The packages you are missing are in the RHEL optional channel, which you need to enable.

yum-config-manager --enable rhui-REGION-rhel-server-extras rhui-REGION-rhel-server-optional

credit: Michael Hampton
Answered July 21, 2019
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA