Skip to main content

Thunderbolt 2 Dock - Display stops working after waking from sleep [Resolved]

I recently bought a used Elgato Thunderbolt 2 dock off ebay and everything seems to be working fine apart from this display issue.

Here are some details of the issue:

  • The monitor is connected to the dock through the HDMI port of the dock.
  • Upon waking from sleep, the display flashes (the flash that occurs when a display is connected or disconnected) and the monitor no longer works and displays a 'No Signal'.
  • To get the display to work again via the dock, the mac has to be restarted.
  • Ethernet, USB ports and headphone/microphone ports of the dock work when this issue occurs.

Some steps I've taken in an attempt to solve/isolate the issue:

  • Connecting a display directly from the mini display-port/thunderbolt port of the Macbook works.
  • Reconnecting the display and thunderbolt cable does not fix the issue.
  • Power cycling the dock (taking out the power adapter and putting it back in) does not work.
  • Using the second thunderbolt port on the Macbook does not work.
  • Disconnecting the HDMI cable from the dock and using the second thunderbolt port on the dock to connect a display via a mini-displayport adapter does not work.
  • Using another Macbook (a different model, more specifically a Macbook Air) works fine.
  • SMC and PRAM resets have been done already. Does not make a difference.
  • Looking at the console, multiple log entries appear which seem to suggest that the HDMI port is being reconnected multiple times:

Console log

My Macbook Details

  • MacBook Pro (Retina, 15-inch, Mid 2015)
  • List item
  • OSX Mojave 10.14.6
  • Intel Core i7 2.8 Ghz
  • 16 GB DDR3
  • 1TB SSD/Flash Storage
  • Intel Iris Pro/AMD Radeon R9 M370X

I've recently done a clean install, coming from the OSX catalina beta. So suggesting this again is out of the question.

Any help is appreciated.


Question Credit: mclarence
Question Reference
Asked August 13, 2019
Posted Under: Apple
13 views
1 Answers

Turning off "Wake for network access" under energy saver in system preferences seemed to have solved this issue.

enter image description here


credit: mclarence
Answered August 13, 2019
Your Answer
D:\Adnan\Candoerz\CandoProject\vQA