Skip to main content

what does ipheth_carrier_set: usb_control_msg: -110 mean [Resolved]

When I connect my girlfriends iphone to my ubuntu mate laptop I am not able to access it.

dmesg -w shows the following log:

[ 1450.188245] usb 1-2: new high-speed USB device number 6 using xhci_hcd
[ 1450.317913] usb 1-2: New USB device found, idVendor=05ac, idProduct=12a8
[ 1450.317918] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1450.317921] usb 1-2: Product: iPhone
[ 1450.317923] usb 1-2: Manufacturer: Apple Inc.
[ 1450.317925] usb 1-2: SerialNumber: c97187dc25fa168592447bcf11c270298d877864
[ 1450.394444] ipheth 1-2:4.2: Apple iPhone USB Ethernet device attached
[ 1450.406295] ipheth 1-2:4.2 enp0s20u2c4i2: renamed from eth0
[ 1450.437139] IPv6: ADDRCONF(NETDEV_UP): enp0s20u2c4i2: link is not ready
[ 1450.438525] IPv6: ADDRCONF(NETDEV_UP): enp0s20u2c4i2: link is not ready
[ 1460.184291] ipheth 1-2:4.2: ipheth_carrier_set: usb_control_msg: -110
[ 1472.184300] ipheth 1-2:4.2: ipheth_carrier_set: usb_control_msg: -110

Yesterday connecting it to the laptop worked for some time, today it does not anymore.

Question Credit: AlexOnLinux
Question Reference
Asked September 19, 2019
Tags: , dmesg, apple, iphone
Posted Under: Unix Linux
1 Answers

Linux kernel error codes are defined in errno.h. The return value is negative, but the code itself is positive, and you'll find

#define ETIMEDOUT   110 /* Connection timed out */

So the iPhone appears as a USB ethernet device, and then the kernel tries to set the (virtual) carrier for this device by sending an USB control message, but this message is not accepted by the iPhone, and times out.

There could be a number of reasons for this. If it worked yesterday, I'd rule out driver problems, so my guess is hardware or cable problems - the initial USB packets transfer fine, but then they stop to work.

credit: dirkt
Answered September 19, 2019
Your Answer